Add patched manta-svn

Signed-off-by: Juraj Oravec <jurajoravec@mailo.com>
This commit is contained in:
Juraj Oravec 2022-07-19 23:03:08 +02:00
commit d8355cd078
Signed by: SGOrava
GPG Key ID: 13660A3F1D9F093B
3 changed files with 176 additions and 0 deletions

52
manta-svn/PKGBUILD Normal file
View File

@ -0,0 +1,52 @@
# Maintainer: <gucong@gc-desktop>
pkgname=manta-svn
pkgver=r2542
pkgrel=1
pkgdesc="a highly portable interactive ray tracing environment"
arch=('i686' 'x86_64')
url="http://mantawiki.sci.utah.edu/manta/Main_Page"
license=('MIT')
depends=('openmpi' 'libx11' 'zlib' 'libgl' 'libmagick6' 'openexr')
makedepends=('subversion' 'cmake')
provides=('manta')
source=('manta-svn::svn+http://anonymous:@gforge.sci.utah.edu/svn/Manta/trunk'
'all.patch'
'cmake.patch')
md5sums=('SKIP'
'dd1faa5da3ec84a3db574ca7fe496f50'
'SKIP')
prepare() {
cd "$srcdir/$pkgname"
patch -p1 -N < "$srcdir/all.patch"
patch -p1 -N < "$srcdir/cmake.patch"
cd "$srcdir"
[[ -d ${pkgname}-build ]] && rm -r ${pkgname}-build
mkdir ${pkgname}-build
}
pkgver() {
# svn checkout --password '' http://anonymous@gforge.sci.utah.edu/svn/Manta/trunk $pkgname
cd "$srcdir/$pkgname"
local ver="$(svnversion)"
printf "r%s" "${ver//[[:alpha:]]}"
}
build() {
cd "$srcdir/${pkgname}-build"
cmake \
-DBUILD_SHARED_LIBS:BOOL=ON \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DCMAKE_C_COMPILER=mpicc \
-DCMAKE_CXX_COMPILER=mpicxx \
-DENABLE_MPI:BOOL=ON \
../$pkgname
make
}
package() {
cd "$srcdir/${pkgname}-build"
make DESTDIR="$pkgdir" install
rm -r "$pkgdir/usr/include/.svn"
}

98
manta-svn/all.patch Normal file
View File

@ -0,0 +1,98 @@
diff -ru trunk/CMake/ConfigCompilerFlags.cmake manta-svn/CMake/ConfigCompilerFlags.cmake
--- trunk/CMake/ConfigCompilerFlags.cmake 2014-07-11 00:51:51.873319318 -0500
+++ manta-svn/CMake/ConfigCompilerFlags.cmake 2014-07-11 00:46:38.919983455 -0500
@@ -263,7 +263,7 @@
APPEND_TO_STRING(INTEL_OPT "-xP -unroll4 -msse3")
ENDIF(CPU_FAMILY EQUAL 15)
ENDIF(VENDOR_ID MATCHES "GenuineIntel")
- APPEND_TO_STRING(GCC_ARCH "i686")
+# APPEND_TO_STRING(GCC_ARCH "i686")
###########################################################
# Some x86_64 specific stuff
diff -ru trunk/Core/Containers/Array3.h manta-svn/Core/Containers/Array3.h
--- trunk/Core/Containers/Array3.h 2014-07-11 00:51:51.983319319 -0500
+++ manta-svn/Core/Containers/Array3.h 2014-07-11 00:46:38.919983455 -0500
@@ -50,6 +50,7 @@
#include <sys/stat.h>
#include <fcntl.h>
#include <Core/Util/Assert.h>
+#include <unistd.h>
namespace Manta {
diff -ru trunk/Core/Thread/Thread.cc manta-svn/Core/Thread/Thread.cc
--- trunk/Core/Thread/Thread.cc 2014-07-11 00:51:52.059985986 -0500
+++ manta-svn/Core/Thread/Thread.cc 2014-07-11 00:46:38.919983455 -0500
@@ -72,6 +72,7 @@
#elif defined(__GNUC__) && defined(__linux)
#include <execinfo.h>
+#include <unistd.h>
#endif
diff -ru trunk/Image/EXRFile.cc manta-svn/Image/EXRFile.cc
--- trunk/Image/EXRFile.cc 2014-07-11 00:51:51.909985985 -0500
+++ manta-svn/Image/EXRFile.cc 2014-07-11 00:46:38.919983455 -0500
@@ -27,8 +27,7 @@
DEALINGS IN THE SOFTWARE.
*/
-
-#include <Image/EXRFile.h>
+#define _NOT_HEADER_
#include <Image/Pixel.h>
#include <Image/SimpleImage.h>
@@ -52,6 +51,7 @@
#include <memory>
#include <exception>
+#include <Image/EXRFile.h>
using namespace Manta;
diff -ru trunk/Image/EXRFile.h manta-svn/Image/EXRFile.h
--- trunk/Image/EXRFile.h 2014-07-11 00:51:51.909985985 -0500
+++ manta-svn/Image/EXRFile.h 2014-07-11 00:46:38.923316788 -0500
@@ -33,13 +33,13 @@
#include <string>
#include <vector>
-
+#ifndef _NOT_HEADER_
namespace Imf
{
class Rgba;
class Header;
}
-
+#endif
namespace Manta
{
diff -ru trunk/Interface/TaskQueue.h manta-svn/Interface/TaskQueue.h
--- trunk/Interface/TaskQueue.h 2014-07-11 00:51:52.416652655 -0500
+++ manta-svn/Interface/TaskQueue.h 2014-07-11 00:51:26.466652446 -0500
@@ -1,6 +1,7 @@
#ifndef MANTA_INTERFACE_TASK_QUEUE_H_
#define MANTA_INTERFACE_TASK_QUEUE_H_
+#include <stddef.h>
#include <Core/Util/SpinLock.h>
#include <Interface/Task.h>
diff -ru trunk/scenes/triangleSceneViewer.cc manta-svn/scenes/triangleSceneViewer.cc
--- trunk/scenes/triangleSceneViewer.cc 2014-07-11 00:51:51.843319318 -0500
+++ manta-svn/scenes/triangleSceneViewer.cc 2014-07-11 00:46:38.939983455 -0500
@@ -37,7 +37,7 @@
#include <algorithm>
#include <iostream>
#include <fstream>
-
+#include <unistd.h>
#include "UsePrivateCode.h"
#ifdef USE_PRIVATE_CODE
Binary files trunk/.svn/wc.db and manta-svn/.svn/wc.db differ

26
manta-svn/cmake.patch Normal file
View File

@ -0,0 +1,26 @@
diff -ru trunk/CMakeLists.txt manta-svn/CMakeLists.txt
--- trunk/CMakeLists.txt 2022-07-19 21:53:49.859712765 +0200
+++ manta-svn/CMakeLists.txt 2022-07-19 22:30:32.266576976 +0200
@@ -8,6 +8,9 @@
# You need at least CMake version 2.4
cmake_minimum_required(VERSION 2.4)
+# Set older C++ standard
+SET(CMAKE_CXX_STANDARD 14)
+
# As of CMake 2.6 Policies were introduced in order to provide a mechanism for
# adding backwards compatibility one feature at a time.
diff -ru trunk/Image/CMakeLists.txt manta-svn/Image/CMakeLists.txt
--- trunk/Image/CMakeLists.txt 2022-07-19 22:53:06.776290555 +0200
+++ manta-svn/Image/CMakeLists.txt 2022-07-19 22:45:44.617527000 +0200
@@ -31,7 +31,7 @@
#############################################
# Look for ImageMagick++
-FIND_PACKAGE(ImageMagick COMPONENTS Magick++)
+FIND_PACKAGE(ImageMagick6 COMPONENTS Magick++)
IF (ImageMagick_Magick++_FOUND)
# Add the ImageMagick files